Vital - Delays in visit updates – Incident details

Delays in visit updates

Resolved
Degraded performance
Started 8 months agoLasted about 2 hours

Affected

SMS

ERAdvisor

CareAdvisor

Updates
  • Resolved
    Resolved

    The changes we implemented to clear the bottleneck in message processing improved throughput, messages in the backlog were processed, and new messages should no longer be delayed.

  • Monitoring
    Monitoring

    An unexpectedly large amount of messages sent into our systems lead to a bottleneck in the message processing, causing delays to all our customers. We have implemented rules to help clear this bottleneck, and are monitoring the situation closely.

  • Identified
    Identified

    We've identified the cause of the issue, and have taken actions to restore live processing of messages. Message queues are gradually draining, but updates may still be delayed.

  • Investigating
    Investigating

    We are currently investigating an issue with a delay in processing information relating to visit updates.